Mint Technology - Outage at Microsoft 365 – Incident details

All systems operational

Outage at Microsoft 365

Resolved
Partial outage
Started 29 days agoLasted about 2 hours

Affected

Cloud

Partial outage from 9:43 PM to 11:19 PM

Microsoft Azure

Partial outage from 9:43 PM to 11:19 PM

Updates
  • Resolved
    Resolved
    This outage now appears to have been resolved. If you are still experiencing issues, please phone us on 09 222 0220.
  • Identified
    Identified
    We are aware of the ongoing Office 365 outage affecting users. As this is a Microsoft issue, We do not currently have an estimated time for repair. If you have any questions, please contact us at 09 222 0220.