Mint Technology - Office 365 Global Outage – Incident details

All systems operational

Office 365 Global Outage

Resolved
Degraded performance
Started 17 days agoLasted about 8 hours

Affected

Cloud

Degraded performance from 8:26 PM to 4:38 AM

Microsoft Azure

Degraded performance from 8:26 PM to 4:38 AM

Updates
  • Resolved
    Resolved
    The outage is now mostly resolved. Mail is now slowly flowing into inboxes that failed earlier. If you are still experiencing issues, please phone us on 09 222 0220.
  • Update
    Update
    Microsoft is aware of this issue and is working towards a repair, however - we do not currently have an estimated time for repair. If you have any questions, please contact us at 09 222 0220.
  • Identified
    Identified
    We are aware of an outage affecting inbound and outbound emails for Office 365. We are investigating the cause and working to resolve the issue as quickly as possible. We do not currently have an estimated time for repair. If you have any questions, please contact us at 09 222 0220.